INCIDENT PROCESSING | Perturbations plateforme de paiement / Payment platform disruptions

Incident Report for Payplug

Postmortem

Post Mortem

Référence incident

TSR-2214

Service concerné

Paiements e-commerce.

Impact client

Les formulaires de paiement hosted-fields des URL de service (endpoint) pointant vers dalenys.com ne s’affichaient plus.

Synthèse de l’incident

  • 29 août : tests sur la configuration de règles sur un pare-feu.
  • 2 septembre 10h47 : déploiement d’une règle sur un pare-feu. Début de l’incident.
  • 2 septembre 11h15 : remontée d’alerte et début des analyses.
  • 2 septembre 11h18 : création d’une cellule de crise dédiée.
  • 2 septembre 11h20 : identification d’une URL de service (endpoint) défectueuse pointant vers le domaine dalenys.com.
  • 2 septembre 11h23 : identification de la mise en place d’une règle de pare-feu coïncidant avec le début de l’incident.
  • 2 septembre 11h25 : communication Statuspage.
  • 2 septembre 11h26 : tentative de désactivation de la règle.
  • 2 septembre 11h30 : suppression de la règle. Fin de l’incident.

Contexte

N/A

Root cause

L’incident a été causé par la mise en place d’une règle de pare-feu.

Actions à entreprendre par Payplug

Symptômes Actions
Erreur humaine lors du déploiement d’une mise en production. Durcissement du processus de déploiement.
Manque de monitoring après une mise en production. Rappel des contrôles à effectuer suite à une mise en production. Ajout d’un contrôle pour vérifier l’intégrité du widget de sélection de marque pour hosted-fields.

==============ENGLISH VERSION==============

Post Mortem

Incident reference

TSR-2214

Payment services affected by the incident

E-commerce.

Client impact

The hosted-fields payment forms from the service URL (endpoints) pointing to dalenys.com were no longer displaying.

Incident Overview

  • 29 August – tests on the configuration of firewall rules.
  • 2 September 10:47amstart of the incident.
  • 2 September 11:15am – alert raised and analysis started.
  • 2 September 11:18am – dedicated crisis unit created.
  • 2 September 11:20am – identification of a faulty service URL (endpoint) pointing to the dalenys.com domain.
  • 2 September 11:23am – identification of a firewall rule implementation coinciding with the start of the incident.
  • 2 September 11:25am – Statuspage communication.
  • 2 September 11:26am – attempt to disable the rule.
  • 2 September 11:30am – deletion of the rule. End of the incident.

Context

N/A

Root cause

The incident was caused by the implementation of a firewall rule.

Actions to be taken by Payplug

Symptômes Actions
Human error during a production deployment. Strengthening of the deployment process.
Lack of monitoring after a production release. Reminder of the checks to be carried out following a production release. Addition of a check to verify the integrity of the brand selection widget for hosted-fields.
Posted Sep 03, 2025 - 16:39 CEST

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 12:12 CEST

Monitoring

TSR-2214
- Début / Start : 02/09/2025 10h47 CEST
- Fin / End : 11h30
- Catégorie / Category : Production - Processing
- Responsabilité / Responsibility : Payplug
- Priorité / Priority : P2


FR
Les url de services dalenys.com ont été indisponibles jusqu’à 11h30.
Le service est revenu en nominal. Nous continuons de monitorer le service.


EN
The dalenys.com service URLs were unavailable until 11:30am.
The service is back to normal. We continue to monitor the service.
Posted Sep 02, 2025 - 11:34 CEST

Investigating

FR
Nous avons identifié des difficultés sur la plateforme de paiement.
L'incident est en cours d'analyse.

EN
We have identified ongoing difficulties on the payment platform.
An investigation is in progress.
Posted Sep 02, 2025 - 11:25 CEST
This incident affected: Processing (Processing e-commerce / E-commerce processing).