INCIDENT PROCESSING | Perturbations formulaires de paiement / Payment forms disruptions

Incident Report for Payplug

Postmortem

English version below

Post Mortem

Référence incident

TSR-2076

Service concerné

Formulaires de paiement Amex & Credorax.

Impact client

Impossibilité d’effectuer des paiements sur les formulaires Amex et Credorax.

Synthèse de l’incident

  • 24 juillet 10h45 : déploiement d’une mise en production.  
  • 24 juillet 10h49 : début de l’incident.
  • 25 juillet 11h57 : rollback de la mise en production. Fin de l’incident. 

Contexte

La détection du dommage collatéral a été défaillante en raison du faible nombre de transactions concernées.

Root cause

Introduction d’un bug dans une mise en production.

Actions à entreprendre par Payplug

Symptômes Actions
Défaillance de détection. Révision du process de déploiement pour garantir l’absence d’impact de la mise en production sur le service.

==============ENGLISH VERSION==============

Post Mortem

Incident reference

TSR-2076

Payment services affected by the incident

Amex & Credorax payment forms.

Client impact

Inability to make payments via the Amex and Credorax forms.

Incident Overview

  • July 24 - 10:45am : production deployment.
  • July 24 -  10:49am : incident begins.
  • July 25 - 11:57 AM: rollback of the production deployment. End of the incident.

Context

Collateral damage detection failed due to the low number of affected transactions.

Root cause

Introduction of a bug during a production release.

Actions to be taken by Payplug

Symptoms Actions
Detection Failure. Deployment process revised to ensure that production releases have no impact on the service.
Posted Jul 28, 2025 - 16:18 CEST

Resolved

FR
Les formulaires de paiements Amex et Credorax ont été dégradés du 24 juillet 10h49 au 25 juillet 11h57.
Un correctif a été appliqué. Le service a été rétabli.

EN
The Amex and Credorax payment forms were degraded from July 24th at 10:49am to July 25th at 11:57 am.
A fix has been applied. The service has been restored.
Posted Jul 25, 2025 - 11:57 CEST