INCIDENT PROCESSING | Perturbations paiement en magasin AMEX / Instore AMEX Payment disruptions

Incident Report for Payplug

Postmortem

English version below

Post Mortem

Référence incident

TSR-1942

Service concerné

Transactions sur carte American Express en paiement magasin.

Impact client

Transactions en erreur 4001.

Synthèse de l’incident

  • 24 juin 14h08 : déploiement d’une mise en production. 
  • 24 juin 14h10 : début de l’incident.
  • 25 juin 15h13 : création d’une cellule incident majeur et début des investigations.
  • 25 juin 15h42 : application d’un fix.
  • 25 juin 15h46 : fin de l’incident.

Contexte

La détection du dommage collatéral a été défaillante en raison du faible nombre de transactions concernées.

Root cause

Introduction d’un bug dans une mise en production.

Actions à entreprendre par Payplug

Symptômes Actions
Défaillance de détection. Révision du process de déploiement pour garantir l’absence d’impact sur le service.

==============ENGLISH VERSION==============

Post Mortem

Incident reference

TSR-1942

Payment services affected by the incident

American Express Card Transactions on in-store Payments.

Client impact

Transactions failed with error code 4001.

Incident Overview

  • 24 June - 2:08pm: production deployment.
  • 24 June - 2:10pm: incident began.
  • 25 June - 3:13pm: major incident task force created and investigations started.
  • 25 June - 3:42pm: fix applied.
  • 25 June - 3:46pm: incident resolved.

Context

The collateral damage went undetected due to the low volume of affected transactions.

Root cause

A bug was introduced during the production deployment.

Actions to be taken by Payplug

Symptoms Actions
Detection Failure. Deployment process to be revised to ensure no impact on the service.
Posted Jun 26, 2025 - 15:08 CEST

Resolved

FR
Les paiements en magasin avec la carte AMEX ont été fortement dégradés depuis le 24 juin vers 14h11
L'incident a été résolu aujourd'hui, mercredi 25 juin, à 15h42.

EN
In-store payments with AMEX cards have been severely degraded since June 24 at 2:11 PM.
The incident was resolved today, Wednesday, June 25, at 3:42 PM.
Posted Jun 24, 2025 - 02:00 CEST