Incident Cockpit affichage transaction indisponible / Transactions display unavailable

Incident Report for Payplug

Postmortem

Post Mortem

Référence incident

TSR-3349

Service concerné

Dashboard & E-commerce.

Impact client

Retard d’affichage des transactions sur le Dashboard et interruption de la fonctionnalité GetTransaction. 

Synthèse de l’incident

  • 1 juin 12h06 : début d'empilement de logs en base qui engendre des ralentissements. Début de l’incident.
  • 1 juin 13h39 : remontées d’alertes indiquant un faible taux de transaction.
  • 1 juin 14h01 : création d’une cellule de crise dédiée et début des investigations.  
  • 1 juin 14h05 : communication Statuspage. 
  • 1 juin 14h16 : identification de l’origine de l’incident. Déploiement d’un correctif pour faire retomber la pile de logs.
  • 1 juin 14h16 - 16h09 : monitoring pour vérifier la baisse continue des logs.
  • 1 juin 16h09 : retour à la normale. Fin de l’incident.

Root cause

Une saturation de la base de données a été provoquée par une accumulation anormale de logs, entraînant un retard dans la remontée des transactions sur le dashboard marchand et des perturbations de la fonctionnalité GetTransaction.

Actions à entreprendre par Payplug

Symptômes Actions
Latence dans la remontée de certaines données. Analyses en cours pour expliquer et accélérer la remontée de ces données spécifiques.
Détection de l’incident lorsque l’impact marchand est constaté. Analyses en cours pour détecter l’empilement de logs, agir proactivement et anticiper un impact pour les marchands.

==============ENGLISH VERSION==============

Post Mortem

Incident reference

TSR-3349

Payment services affected by the incident

Dashboard & E-commerce.

Client impact

Delay in the display of transactions on the Dashboard and disruption of the GetTransaction functionality.

Incident Overview

  • 1 June - 12:06pm: log accumulation in the database begins, causing performance degradation. Start of the incident.
  • 1 June - 1:39pm: alerts raised indicating a low transaction success rate.
  • 1 June - 2:01pm: dedicated crisis cell established and investigations started.
  • 1 June - 2:05pm: Statuspage communication published.
  • 1 June - 2:16pm: root cause identified. Deployment of a fix to reduce the backlog of logs.
  • 1 June - 2:16pm–4:09pm: monitoring carried out to verify the continuous reduction of the log backlog.
  • 1 June - 4:09pm: service returned to normal. End of the incident. 

Root cause

Database saturation was caused by an abnormal accumulation of logs, resulting in a delay in the display of transactions on the merchant dashboard and disruptions to the GetTransaction functionality.

Actions to be taken by Payplug

Symptoms Actions
Latency in the processing and display of certain data. Ongoing investigations to determine the cause and accelerate the processing of these specific data sets.
The incident was detected once merchant impact was observed. Ongoing analysis to detect log accumulation earlier, take proactive action, and prevent any impact on merchants.
Posted Jun 02, 2026 - 09:59 CEST

Resolved

TSR-3349
- Début / Start : 01/06/2026 11h CEST
- Fin / End : 01/06/2026 16h05 CEST
- Catégorie / Category : Production Cockpit
- Responsabilité / Responsibility : Payplug
- Priorité / Priority : P2

FR
L'affichage des transactions est revenue à la normale.

EN
Transaction display has returned to normal.
Posted Jun 01, 2026 - 16:12 CEST

Monitoring

TSR-3349
- Début / Start : 01/06/2026 11h CEST
- Fin / End : En cours / Ongoing
- Catégorie / Category : Production Cockpit
- Responsabilité / Responsibility : Payplug
- Priorité / Priority : P2

FR
La fonctionnalité getTransaction a été impactée et les paiements étant validés par cette fonctionnalité sont tombés en erreurs.
Suite au correctif, la situation est en train de revenir à la normale.
Nous continuons de monitorer le service.

EN
The getTransaction functionality was impacted, and payments validated through this functionality failed.
Following the deployment of the fix, the situation is returning to normal.
We will continue to monitor the service.
Posted Jun 01, 2026 - 14:35 CEST

Identified

TSR-3349
- Début / Start : 01/06/2026
- Fin / End : En cours / Ongoing
- Catégorie / Category : Production Cockpit
- Responsabilité / Responsibility : Payplug
- Priorité / Priority : P2

FR
L'origine de l'incident a été identifié.
Un correctif est en cours de déploiement.

EN
The root cause of the incident has been identified.
A fix is currently being deployed.
Posted Jun 01, 2026 - 14:20 CEST

Investigating

FR
Nous avons identifié un problème d'affichage des transactions sur notre Cockpit.
L'incident est en cours d'analyse.

EN
We have identified a transaction display issue on our Cockpit.
An investigation is in progress.
Posted Jun 01, 2026 - 14:05 CEST
This incident affected: Dashboard & Reporting (Dashboard / Cockpit / Extranet / Reporting).